Seite 1 von 1

Fehler beim Update von 19.2 auf 19.3

Verfasst: Do 31. Okt 2019, 16:55
von klsfsthar
Hallo,

ich habe einen Update von Version 19.2 auf 19.3 vorgenommen danach erscheint folgender Fehler. Software ist nicht mehr nutzbar:

Definition can't be created. "Xentral\Components\Database\Bootstrap::onInitExtendedPdo" is not callable.

Version ist:

SOFTWARE
Xentral-Revision: 19.3.7a1e19a
Xentral-Version: OSS
FPDF-Version: 3

Was kann ich tun?

Vielen Dank

Re: Fehler beim Update von 19.2 auf 19.3

Verfasst: Do 31. Okt 2019, 19:34
von sauterbe
ist auf dem Server PHP 7.2 installiert?

Re: Fehler beim Update von 19.2 auf 19.3

Verfasst: Do 31. Okt 2019, 20:01
von klsfsthar
Server ist noch auf 5.6. Muss ich hochziehen.

Danke!

Re: Fehler beim Update von 19.2 auf 19.3

Verfasst: So 17. Nov 2019, 12:42
von klsfsthar
Hallo,

ich habe nunmehr eine neue VM mit php 7.3.11 am laufen. Xentral übernommen und laufe weiter nach dem Update von 19.2 auf 19.3 auf den Fehler:

Xentral: Es ist ein unerwarteter Fehler aufgetreten!
Definition can't be created. "Xentral\Components\Database\Bootstrap::onInitExtendedPdo" is not callable.

Xentral \ Core \ DependencyInjection \ Exception \ InvalidArgumentException
Definition can't be created. "Xentral\Components\Database\Bootstrap::onInitExtendedPdo" is not callable.
/opt/bitnami/apache2/htdocs/lmwawip01/classes/Core/DependencyInjection/Definition/FactoryMethodDefinition.php:24

7 Xentral\Core\DependencyInjection\Definition\FactoryMethodDefinition→__construct()
/opt/bitnami/apache2/htdocs/lmwawip01/classes/Core/DependencyInjection/ServiceRegistry.php:123

6 Xentral\Core\DependencyInjection\ServiceRegistry→addFactory()
/opt/bitnami/apache2/htdocs/lmwawip01/classes/Core/DependencyInjection/ServiceRegistry.php:132

5 Xentral\Core\DependencyInjection\ServiceRegistry→addFactories()
/opt/bitnami/apache2/htdocs/lmwawip01/classes/bootstrap.php:56

4 →include()
/opt/bitnami/apache2/htdocs/lmwawip01/phpwf/class.application_core.php:119

3 ApplicationCore→__construct()
/opt/bitnami/apache2/htdocs/lmwawip01/phpwf/class.application.php:119

2 Application→__construct()
/opt/bitnami/apache2/htdocs/lmwawip01/www/eproosystem.php:147

1 erpooSystem→__construct()
/opt/bitnami/apache2/htdocs/lmwawip01/www/index.php:60

Re: Fehler beim Update von 19.2 auf 19.3

Verfasst: Do 21. Nov 2019, 15:25
von sauterbe
wenn man php 7.2 verwendet? was ist dann

Re: Fehler beim Update von 19.2 auf 19.3

Verfasst: Do 21. Nov 2019, 16:07
von andrejohn
Ich habe es vom ersten Tag an auf 7.3 laufen. Hatte das Problem nicht

Re: Fehler beim Update von 19.2 auf 19.3

Verfasst: Di 26. Nov 2019, 13:27
von sauterbe
ist im Screenshot links etwas rot oder gelb markiert? Ein PHP Modul das eventuell fehlt?

Re: Fehler beim Update von 19.2 auf 19.3

Verfasst: So 1. Dez 2019, 18:22
von klsfsthar
Hallo,

habe jetzt 19.3 zum laufen gebracht. Es fehlte die ionCube-Extension für php. ionCube muss bereits vor dem Update verfügbar sein. Dann läuft der Update auch durch.

Re: Fehler beim Update von 19.2 auf 19.3

Verfasst: Fr 13. Dez 2019, 17:49
von sauterbe
danke für das feedback